Networking issues in London region
Incident Report for Fanout
Resolved
This incident has been resolved.
Posted Mar 19, 2020 - 10:04 UTC
Investigating
We are currently investigating this issue.
Posted Mar 19, 2020 - 08:27 UTC
This incident affected: POP - London.